Degraded server performance in US and Canada
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted Apr 18, 2018 - 20:03 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2018 - 18:52 EDT
Investigating
We are currently investigating this issue.
Posted Apr 18, 2018 - 18:49 EDT