Delay in call connection
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted Apr 04, 2019 - 18:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2019 - 18:32 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 04, 2019 - 17:52 EDT
Investigating
We are currently investigating this issue.
Posted Apr 04, 2019 - 17:11 EDT
This incident affected: Voice - Inbound Browser Calls and Voice - Outbound Browser Calls.