Degraded server performance
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted Jul 13, 2018 - 18:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2018 - 16:59 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 13, 2018 - 16:59 EDT
Investigating
We are currently investigating this issue.
Posted Jul 13, 2018 - 16:53 EDT
This incident affected: Canadian Servers and U.S. Servers.