Issue with Email delivery to the Ticketing System
Incident Report for Nectar Desk
Resolved
Issue has been resolved.
Posted Oct 20, 2017 - 07:49 EDT
Investigating
We are experiencing issues with Emails delivery to Nectar Desk. Our technical team is investigating.
Posted Oct 19, 2017 - 18:07 EDT