Intermittent inbound call failures with US & Canada DIDs
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted Mar 06, 2018 - 13:52 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 06, 2018 - 13:34 EST
Investigating
We are currently investigating this issue.
Posted Mar 06, 2018 - 12:21 EST