UK DIDs partially affected
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted Dec 21, 2017 - 15:48 EST
Investigating
One of our local carriers in UK is experiencing a partial network outage. Incoming Voice/SMS is affected to some of our UK numbers.
We are working with the carrier to resolve this soon. More updates to follow.
Posted Dec 21, 2017 - 11:21 EST