Incoming call issues on some accounts
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted Feb 14, 2018 - 15:47 EST
Investigating
We are currently investigating this issue.
Posted Feb 14, 2018 - 12:45 EST