Inbound Voice Calls affected for North American area code 1-250 and 1-254
Incident Report for Nectar Desk
Resolved
This incident has been resolved.
Posted May 30, 2018 - 16:33 EDT
Investigating
We are currently investigating this issue.
Posted May 30, 2018 - 10:33 EDT
This incident affected: Voice - Inbound Browser Calls.